Skip to main content
← All vulnerabilities
CVE-2020-11020GHSA-QPG4-4W7W-2MQ5

Authentication and extension bypass in Faye

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.4, 1.1.3, 1.2.5
None on Exploit-DB, Metasploit or GitHub

Summary

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • faye Faye

    From 0.5.0 · fixed in 1.0.4; From 1.1.0 · fixed in 1.1.3; From 1.2.0 · fixed in 1.2.5

  • fayeRubyGems

    From 0.5.0 · fixed in 1.0.4

  • fayeRubyGems

    From 1.1.0 · fixed in 1.1.3

  • fayeRubyGems

    From 1.2.0 · fixed in 1.2.5

References 2

GitHub · faye/faye