Skip to main content
← All vulnerabilities
CVE-2020-11001PYSEC-2020-152GHSA-V2WC-PFQ2-5CM6

Possible XSS attack in Wagtail

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.2, 2.8.1
None on Exploit-DB, Metasploit or GitHub

Summary

In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • wagtail wagtail

    fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

  • wagtailPyPI

    From 1.9 · fixed in 2.7.2

  • wagtailPyPI

    From 1.9.0 · fixed in 2.7.2

  • wagtailPyPI

    From 2.8.0 · fixed in 2.8.1

References 1

GitHub · wagtail/wagtail