Skip to main content
← All vulnerabilities
CVE-2020-10806GHSA-54P5-GXQ6-J98G

eZ Publish Kernel before 5.4.14.1, 6.x before 6.13.6.2, and 7.x before 7.5.6.2 and eZ Publish Legacy before 5.4.14.1, 2017 before 2017.12.7.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.4.14.1, 6.13.6.2, 7.5.6.2, 2017.12.7.2, 2019.03.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

eZ Publish Kernel before 5.4.14.1, 6.x before 6.13.6.2, and 7.x before 7.5.6.2 and eZ Publish Legacy before 5.4.14.1, 2017 before 2017.12.7.2, and 2019 before 2019.03.4.2 allow remote attackers to execute arbitrary code by uploading PHP code, unless the vhost configuration permits only app.php execution.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • ezsystems/ezpublish-kernelPackagist

    fixed in 5.4.14.1

  • ezsystems/ezpublish-legacyPackagist

    fixed in 5.4.14.1

  • ezsystems/ezpublish-kernelPackagist

    From 6.0 · fixed in 6.13.6.2

  • ezsystems/ezpublish-kernelPackagist

    From 7.0 · fixed in 7.5.6.2

  • ezsystems/ezpublish-legacyPackagist

    From 2017 · fixed in 2017.12.7.2

  • ezsystems/ezpublish-legacyPackagist

    From 2019 · fixed in 2019.03.4.2

References 1

ezplatform.com