Skip to main content
← All vulnerabilities
CVE-2020-10738GHSA-VR6V-G96P-CJC3BIT-MOODLE-2020-10738

A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported version

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.8.3, 3.7.6, 3.6.10, 3.5.12
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] moodle

    3.8 to 3.8.2, 3.7 to 3.7.5, 3.6 to 3.6.9, 3.5 to 3.5.11

  • moodle/moodlePackagist

    From 3.8 · fixed in 3.8.3

  • moodle/moodlePackagist

    From 3.7 · fixed in 3.7.6

  • moodle/moodlePackagist

    From 3.6 · fixed in 3.6.10

  • moodle/moodlePackagist

    From 3.5 · fixed in 3.5.12

References 3

bugzilla.redhat.com

moodle.org

git.moodle.org