Skip to main content
← All vulnerabilities
CVE-2020-10691PYSEC-2020-2GHSA-3C67-GC48-983W

An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.9.7
None on Exploit-DB, Metasploit or GitHub

Summary

An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. When extracting a collection .tar.gz file, the directory is created without sanitizing the filename. An attacker could take advantage to overwrite any file within the system.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Red Hat Ansible

    all ansible-engine versions 2.9.x prior to 2.9.7

  • ansiblePyPI

    From 2.9.0 · fixed in 2.9.7

  • ansiblePyPI

    From 2.9.0a1 · fixed in 2.9.7

References 2

bugzilla.redhat.com

GitHub · ansible/ansible