A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_fa
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.17, 2.8.9, 2.9.6, 2.8.11, 2.9.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat Ansible
all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.9, all Ansible 2.9.x versions prior to 2.9.6
- ansiblePyPI
From 2.7.0 · fixed in 2.7.17; From 2.8.0 · fixed in 2.8.9; From 2.9.0 · fixed in 2.9.6
- ansiblePyPI
From 2.7.0a1 · fixed in 2.7.17
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.11
- ansiblePyPI
From 2.9.0a1 · fixed in 2.9.7