Skip to main content
← All vulnerabilities
CVE-2019-8331GHSA-9V3M-8FP8-MJ99

In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.3.1, 3.4.1, 5.3.0
3 proofs of concept on GitHub

Summary

In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • bootstrapRubyGems

    fixed in 4.3.1

  • bootstrap-sassRubyGems

    From 3.0.0 · fixed in 3.4.1

  • Bootstrap.LessNuGet

    From 3.0.0 · fixed in 3.4.1

  • bootstrapNuGet

    From 4.0.0 · fixed in 4.3.1

  • bootstrapNuGet

    From 3.0.0 · fixed in 3.4.1

  • bootstrap.sassNuGet

    fixed in 4.3.1

  • bootstrapnpm

    From 4.0.0 · fixed in 4.3.1

  • bootstrapnpm

    From 3.0.0 · fixed in 3.4.1

  • bootstrap-sassnpm

    From 3.0.0 · fixed in 3.4.1

  • twitter-bootstrap-railsRubyGems

    fixed in 5.3.0

  • org.webjars:bootstrapMaven

    From 3.0.0 · fixed in 3.4.1

  • org.webjars:bootstrapMaven

    From 4.0.0 · fixed in 4.3.1

  • twbs/bootstrapPackagist

    From 3.0.0 · fixed in 3.4.1

  • twbs/bootstrapPackagist

    From 4.0.0 · fixed in 4.3.1

References 28

securityfocus.com

seclists.org

access.redhat.com

lists.apache.org

packetstormsecurity.com

oracle.com

GitHub · twbs/bootstrap

blog.getbootstrap.com

support.f5.com

GitHub · Snorlyd/https-nj.gov---CVE-2019-8331

GitHub · Thampakon/CVE-2019-8331

GitHub · Yumeae/Bootstrap-with-XSS