Skip to main content
← All vulnerabilities
CVE-2019-8325GHSA-4WM8-FJV7-J774

An issue was discovered in RubyGems 2.6 and later through 3.0.2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.9, 3.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • rubygems-updateRubyGems

    From 2.6.0 · fixed in 2.7.9

  • rubygems-updateRubyGems

    From 3.0.0 · fixed in 3.0.2

References 3

hackerone.com

lists.opensuse.org

lists.debian.org