Skip to main content
← All vulnerabilities
CVE-2019-8324GHSA-76WM-422Q-92MQ

An issue was discovered in RubyGems 2.6 and later through 3.0.2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.9, 3.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • rubygems-updateRubyGems

    From 2.6.0 · fixed in 2.7.9

  • rubygems-updateRubyGems

    From 3.0.0 · fixed in 3.0.2

References 4

hackerone.com

lists.opensuse.org

access.redhat.com

lists.debian.org