Skip to main content
← All vulnerabilities
CVE-2019-8159GHSA-47H6-HFPV-7PHJ

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.10, 2.3.2-p2
None on Exploit-DB, Metasploit or GitHub

Summary

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with system data manipulation privileges can execute aribitrary code through arbitrary file deletion and OS command injection.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Systems Incorporated Magento 2

    Magento 2.2 prior to 2.2.10

  • magento/community-editionPackagist

    From 2.2 · fixed in 2.2.10

  • magento/community-editionPackagist

    From 2.3 · fixed in 2.3.2-p2

References 1

magento.com