Skip to main content
← All vulnerabilities
CVE-2019-8152GHSA-JJMG-XMQ2-G6FF

A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.10, 2.3.2-p2
None on Exploit-DB, Metasploit or GitHub

Summary

A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Systems Incorporated Magento 1 & 2

    Magento Open Source prior to 1.9.4.3, and Magento Commerce prior to 1.14.4.3, Magento 2.2 prior to 2.2.10

  • magento/community-editionPackagist

    From 2.2.0 · fixed in 2.2.10

  • magento/community-editionPackagist

    From 2.3 · fixed in 2.3.2-p2

References 1

magento.com