Skip to main content
← All vulnerabilities
CVE-2019-8143GHSA-94Q8-GX29-6MQV

A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.10, 2.3.2-p1
None on Exploit-DB, Metasploit or GitHub

Summary

A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to email templates can send malicious SQL queries and obtain access to sensitive information stored in the database.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Systems Incorporated Magento 2

    Magento 2.2 prior to 2.2.10

  • magento/community-editionPackagist

    From 2.2 · fixed in 2.2.10

  • magento/community-editionPackagist

    From 2.3 · fixed in 2.3.2-p1

References 1

magento.com