Skip to main content
← All vulnerabilities
CVE-2019-8141GHSA-9WR9-FW9V-8FGR

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.19, 2.2.10, 2.3.3
None on Exploit-DB, Metasploit or GitHub

Summary

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with administrative privileges (system level import) can execute arbitrary code through a Phar deserialization vulnerability in the import functionality.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Systems Incorporated Magento 2

    Magento 2.2 prior to 2.2.10

  • magento/community-editionPackagist

    From 2.1.0 · fixed in 2.1.19

  • magento/community-editionPackagist

    From 2.2.0 · fixed in 2.2.10

  • magento/community-editionPackagist

    From 2.3.0 · fixed in 2.3.3

References 1

magento.com