Skip to main content
← All vulnerabilities
CVE-2019-8121GHSA-89CH-HQF9-RGP3

An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.10, 2.3.3, 2.3.2-p2
None on Exploit-DB, Metasploit or GitHub

Summary

An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Magento 2 codebase leveraged outdated versions of JS libraries (Bootstrap, jquery, Knockout) with known security vulnerabilities.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Systems Incorporated Magento 2

    Version range not reported

  • magento/community-editionPackagist

    From 2.2 · fixed in 2.2.10

  • magento/community-editionPackagist

    From 2.3 · fixed in 2.3.3

  • magento/product-community-editionPackagist

    From 2.2 · fixed in 2.2.10

  • magento/product-community-editionPackagist

    From 2.3 · fixed in 2.3.2-p2

References 1

magento.com