CVE-2019-8120GHSA-985W-MQQP-7287
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.1.19, 2.2.10, 2.3.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user can inject arbitrary Javascript code by manipulating section of a POST request related to customer's email address.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Systems Incorporated Magento 2
Version range not reported
- magento/community-editionPackagist
From 2.1.0 · fixed in 2.1.19
- magento/community-editionPackagist
From 2.2.0 · fixed in 2.2.10
- magento/community-editionPackagist
From 2.3.0 · fixed in 2.3.3