CVE-2019-8114GHSA-CRV7-R357-GW3W
A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.9.4.3, 2.2.10, 2.3.2-p2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Systems Incorporated Magento 1 & 2
Magento Open Source prior to 1.9.4.3, and Magento Commerce prior to 1.14.4.3, Magento 2.2 prior to 2.2.10
- magento/community-editionPackagist
fixed in 1.9.4.3
- magento/community-editionPackagist
From 2.2.0 · fixed in 2.2.10
- magento/community-editionPackagist
From 2.3.0 · fixed in 2.3.2-p2
- magento/project-community-editionPackagist
fixed in 1.9.4.3