CVE-2019-8110GHSA-GFCQ-WH3G-C6H4
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.2.10, 2.3.2-p1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can leverage email templates hierarchy to manipulate the interceptor class in a way that allows an attacker to execute arbitrary code.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Systems Incorporated Magento 2
Magento 2.2 prior to 2.2.10
- magento/community-editionPackagist
From 2.2.0 · fixed in 2.2.10
- magento/community-editionPackagist
From 2.3.0 · fixed in 2.3.2-p1