Skip to main content
← All vulnerabilities
CVE-2019-7936GHSA-MF6X-7766-5CG8

A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.2, 2.2.9, 2.1.18
None on Exploit-DB, Metasploit or GitHub

Summary

A stored cross-site scripting vulnerability exists in the admin panel of Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify content block titles to inject malicious javascript.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Magento 2

    Version range not reported

  • magento/community-editionPackagist

    From 2.3.0 · fixed in 2.3.2

  • magento/community-editionPackagist

    From 2.2.0 · fixed in 2.2.9

  • magento/community-editionPackagist

    From 2.1.0 · fixed in 2.1.18

References 1

magento.com