Skip to main content
← All vulnerabilities
CVE-2019-7903GHSA-JHVH-MJFG-5M99

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.18, 2.2.9, 2.3.2
None on Exploit-DB, Metasploit or GitHub

Summary

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to email templates can execute arbitrary code by previewing a malicious template.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Magento 2

    Version range not reported

  • magento/community-editionPackagist

    From 2.1.0 · fixed in 2.1.18

  • magento/community-editionPackagist

    From 2.2.0 · fixed in 2.2.9

  • magento/community-editionPackagist

    From 2.3.0 · fixed in 2.3.2

References 1

magento.com