Skip to main content
← All vulnerabilities
CVE-2019-7882GHSA-FF7R-7RRM-WX6W

A stored cross-site scripting vulnerability exists in the WYSIWYG editor of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.18, 2.2.9, 2.3.2
None on Exploit-DB, Metasploit or GitHub

Summary

A stored cross-site scripting vulnerability exists in the WYSIWYG editor of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to the editor can inject malicious SWF files.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Magento 1 Magento 2

    Version range not reported

  • magento/community-editionPackagist

    From 2.1 · fixed in 2.1.18

  • magento/community-editionPackagist

    From 2.2 · fixed in 2.2.9

  • magento/community-editionPackagist

    From 2.3 · fixed in 2.3.2

References 1

magento.com