CVE-2019-7858GHSA-7H8V-F2G9-39FX
A cryptographic flaw in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9 and Magento 2.3 prior to 2.3.2 resulted in storage of sensit
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.1.18, 2.2.9, 2.3.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A cryptographic flaw in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9 and Magento 2.3 prior to 2.3.2 resulted in storage of sensitive information with an algorithm that is insufficiently resistant to brute force attacks.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Magento 2
Version range not reported
- magento/community-editionPackagist
From 2.1.0 · fixed in 2.1.18
- magento/community-editionPackagist
From 2.2.0 · fixed in 2.2.9
- magento/community-editionPackagist
From 2.3.0 · fixed in 2.3.2