Skip to main content
← All vulnerabilities
CVE-2019-7857GHSA-F6WW-VQW2-XP3V

A cross-site request forgery vulnerability in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 can cause

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.9, 2.1.18, 2.3.2
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site request forgery vulnerability in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 can cause unwanted items to be added to a shopper's cart due to an insufficiently robust anti-CSRF token implementation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Magento 2

    Version range not reported

  • magento/community-editionPackagist

    From 2.2.0 · fixed in 2.2.9

  • magento/community-editionPackagist

    From 2.1.0 · fixed in 2.1.18

  • magento/community-editionPackagist

    From 2.3.0 · fixed in 2.3.2

References 1

magento.com