CVE-2019-7139GHSA-4J6W-9RF8-HG7R
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.1.18, 2.2.9, 2.3.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub, 1 Nuclei template
Summary
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Magento Magento Open Source
prior to 1.9.4.1
- Magento Magento Commerce
prior to 1.14.4.1
- Magento Magento
prior to 2.1.17, prior to 2.2.8, prior to 2.3.1
- magento/community-editionPackagist
From 2.1.0 · fixed in 2.1.18
- magento/community-editionPackagist
From 2.2.0 · fixed in 2.2.9
- magento/community-editionPackagist
From 2.3.0 · fixed in 2.3.2