Skip to main content
← All vulnerabilities
CVE-2019-6341GHSA-CMMH-8MWP-GQ5PDRUPAL-CORE-2019-004

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2019-004

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.65, 8.6.13, 8.5.14, 7.65.0
None on Exploit-DB, Metasploit or GitHub

Summary

In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Drupal Drupal core

    From Drupal 7 · fixed in 7.65; From Drupal 8.6 · fixed in 8.6.13; From Drupal 8.5 · fixed in 8.5.14

  • drupal/corePackagist

    From 7.0.0 · fixed in 7.65.0

  • drupal/corePackagist

    From 8.0.0 · fixed in 8.5.14

  • drupal/corePackagist

    From 8.6.0 · fixed in 8.6.13

  • drupal/drupalPackagist

    From 7.0.0 · fixed in 7.65.0

  • drupal/drupalPackagist

    From 8.0.0 · fixed in 8.5.14

  • drupal/drupalPackagist

    From 8.6.0 · fixed in 8.6.13

  • drupal/corePackagist

    From 8.0.0 · fixed in 8.5.14; From 8.6.0 · fixed in 8.6.13

References 7

drupal.org

lists.debian.org

synology.com

lists.fedoraproject.org