Skip to main content
← All vulnerabilities
CVE-2019-6339DRUPAL-CORE-2019-002GHSA-8CW5-RV98-5C46

PHAR stream wrapper Arbitrary PHP code execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.62, 8.6.6., 8.5.9, 8.6.6, 7.62.0
1 proof of concept on GitHub

Summary

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Drupal Drupal core

    From 7.x · fixed in 7.62; From 8.6.x · fixed in 8.6.6.; From 8.5.x · fixed in 8.5.9

  • drupal/corePackagist

    From 8.0.0 · fixed in 8.5.9; From 8.6.0 · fixed in 8.6.6

  • drupal/drupalPackagist

    From 7.0.0 · fixed in 7.62.0

  • drupal/drupalPackagist

    From 8.0.0 · fixed in 8.5.9

  • drupal/drupalPackagist

    From 8.6.0 · fixed in 8.6.6

  • drupal/corePackagist

    From 7.0.0 · fixed in 7.62.0

  • drupal/corePackagist

    From 8.0.0 · fixed in 8.5.9

  • drupal/corePackagist

    From 8.6.0 · fixed in 8.6.6

References 4

debian.org

drupal.org

lists.debian.org

GitHub · Vulnmachines/drupal-cve-2019-6339