CVE-2019-5432GHSA-WV67-9JQ7-8R69
A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.5.1, 4.1.3, 5.6.1, 6.1.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a mqtt-packet
Version range not reported
- mqtt-packetnpm
fixed in 3.5.1
- mqtt-packetnpm
From 4.0.0 · fixed in 4.1.3
- mqtt-packetnpm
From 5.0.0 · fixed in 5.6.1
- mqtt-packetnpm
From 6.0.0 · fixed in 6.1.2