CVE-2019-5064GHSA-Q799-Q27X-VP7WPYSEC-2026-2802PYSEC-2026-2828PYSEC-2026-2841PYSEC-2026-725
An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, before version 4.2.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.2.0.32
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, before version 4.2.0. A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a OpenCV
OpenCV 4.1.0
- opencv-pythonPyPI
fixed in 4.2.0.32
- opencv-python-headlessPyPI
fixed in 4.2.0.32
- opencv-contrib-pythonPyPI
fixed in 4.2.0.32
- opencv-contrib-python-headlessPyPI
fixed in 4.2.0.32
- opencv-pythonPyPI
fixed in 4.2.0.32
- opencv-contrib-python-headlessPyPI
fixed in 4.2.0.32