CVE-2019-3849GHSA-5WG9-5W3F-HXMH
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.4.8, 3.5.5, 3.6.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
3.6.3, 3.5.5, 3.4.8
- moodle/moodlePackagist
fixed in 3.4.8
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.5
- moodle/moodlePackagist
From 3.6 · fixed in 3.6.3