CVE-2019-3848GHSA-45RW-4R25-JVG7
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.4.8, 3.5.5, 3.6.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
3.6.3, 3.5.5, 3.4.8
- moodle/moodlePackagist
From 3.4 · fixed in 3.4.8
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.5
- moodle/moodlePackagist
From 3.6 · fixed in 3.6.3