CVE-2019-3847GHSA-QRCJ-6FJW-3H9H
A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.3, 3.5.5, 3.4.8, 3.1.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Users with the "login as other users" capability (such as administrators/managers) can access other users' Dashboards, but the JavaScript those other users may have added to their Dashboard was not being escaped when being viewed by the user logging in on their behalf.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] Moodle
3.6 to 3.6.2, 3.5 to 3.5.4, 3.4 to 3.4.7
- moodle/moodlePackagist
From 3.6.0 · fixed in 3.6.3
- moodle/moodlePackagist
From 3.5.0 · fixed in 3.5.5
- moodle/moodlePackagist
From 3.2.0 · fixed in 3.4.8
- moodle/moodlePackagist
fixed in 3.1.17